Home » Noticias » Apple obligará a soportar 64 bits e iOS 8 desde febrero de 2015
64 bits

Apple obligará a soportar 64 bits e iOS 8 desde febrero de 2015

Hoy, 20 de octubre, hemos visto una nueva jornada de actualizaciones, como continuación de la que vivimos el pasado jueves 16 con el lanzamiento de OS X Yosemite final.

Hoy, hemos visto el lanzamiento de iOS 8.1, con la corrección de numerosos errores y la implementación de Apple Pay (solo en Estados Unidos) y el lanzamiento de Xcode 6.1 final con soporte de Swift también para OS X, tanto en proyectos como Playground.

Pero junto a estos lanzamientos y en una escueta nota en la página de noticias del portal de desarrolladores de Apple, nos encontramos con un cambio muy importante en todas las apps que vayan a subir a la App Store a partir del 1 de febrero de 2015.

Noticia iOS 8 y 64 bits

A partir del 1 de febrero de 2015, las nuevas apps de iOS subidas a la App Store deben incluir soporte de 64 bits y estar construidas con la SDK de iOS 8, incluida en Xcode 6 y superior. Para habilitar los 64 bits en su proyecto, recomendamos usar la configuración por defecto “standard architectures” para construir un binario sencillo con ambas versiones de código en 32 y 64 bits.

Más claro, imposible. A partir de dicha fecha, aunque soportemos versiones anteriores de iOS, el kit de base para todos los desarrollos debe ser iOS 8 e incluir los binarios en 64 bits para los procesadores A7, A8 y A8X de Apple junto al binario de 32 bits para dispositivos anteriores.

Esto obliga a actualizar multitud de desarrollos (si queremos darles continuidad) que estén hechos con herramientas o frameworks de terceros en versiones antiguas, entre otros. Por ejemplo, si tenemos algún videojuego publicado y hecho en Cocos2D 1 o 2, tendremos que actualizarlos a la versión 3 si queremos subir una actualización posteriormente al 1 de febrero del próximo año.

Por ahora, no es obligatorio que las apps soporten las nuevas resoluciones del iPhone 6 y 6 Plus, pero recordemos que desde hace ya tiempo sí es obligatorio que todas las apps soporten la resolución de los iPhone de 4″ (5/5c/5s).

Igualmente, si queremos usar Swift para nuestras apps (una buena elección para soportar 64 bits sin problema), este solo puede ser ejecutado en iOS 7 o superior.

Así que, con un cuantos meses de tiempo, podemos empezar a planificar las necesarias actualizaciones de nuestras apps y juegos para esta nueva exigencia de la App Store que entrará en vigor el próximo 1 de febrero de 2015. Fecha que podría tal vez coincidir con el lanzamiento del Apple Watch (se me ocurre) y el futuro Apple TV con A7 y juegos.

Acerca de Julio César Fernández

Analista, consultor y periodista tecnológico, desarrollador, empresario, productor audiovisual, actor de doblaje e ingeniero de vídeo y audio.

Otras recomendaciones

App Store Review Guidelines iOS 11

Cambios en las normas del App Store en iOS 11

Todos sabemos cómo son las normas del App Store (o deberíamos saberlas) y la importancia …